WordPress 5.5 Breaks Plugins & Sites: voici le correctif


La récente mise à jour de WordPress 5.5 a provoqué le plantage et le comportement de nombreux plugins et sites. Mais vous corrigez les problèmes de mise à jour de WordPress avec l’aide de jQuery Migrate.

WordPress 5.5 a récemment été rendu public. WordPress l’a marqué du surnom « Eckstine«. Outre la nouvelle image de marque, de nombreuses nouvelles fonctionnalités et mises à jour ont également été annoncées.

Cependant, pour certaines personnes, ces nouvelles mises à jour font en fait le contraire d’améliorer les performances de leur site. De nombreux propriétaires de sites ont signalé que WordPress 5.5 cassait les plugins et les sites.

Si vous êtes un propriétaire de site, qui est affecté par les récents changements de WordPress, ne vous inquiétez pas. Passons en revue la solution et résolvons les problèmes de votre site Web.

WordPress 5.5 rompt les plugins

Quand le problème a-t-il commencé

WordPress a publié la version 5.5 alias «Eckstine» le 11 août 2020. Immédiatement après, certains développeurs et propriétaires de sites ont commencé à remarquer puis à signaler différents types de problèmes.

De nombreux sites ont commencé à afficher des problèmes lorsque les fenêtres contextuelles et les menus déroulants ont cessé de fonctionner. Mais le problème majeur était que des plugins comme Yoast SEO, Classic Editor ne fonctionnaient plus correctement. De nombreux propriétaires de sites étaient en difficulté avec la rupture de Yoast SEO, qui est l’un des plugins les plus utilisés pour les sites WordPress. Certains d’entre eux essaient même de revenir à la version 5.4.2 pour résoudre ce problème.

Pourquoi WordPress 5.5 rompt les plugins et les sites

Le problème qui a déclenché la rupture des plugins et des sites après la mise à jour de WordPress 5.5 était que WordPress a supprimé jQuery Migrate. Bien que de nombreuses personnes l’aient remarqué après la sortie de WordPress 5.5, sa suppression avait été annoncée 2 mois auparavant. Les développeurs ont également été invités à mettre à jour les plugins et les thèmes en conséquence.

Avec la suppression de cet outil, les plugins et les thèmes avec un noyau obsolète ont cessé de fonctionner correctement. Cela a entraîné une situation désastreuse pour certains propriétaires de sites, qui ont trouvé leur site se comporter bizarrement.

WordPress 5.5 Breaks Plugins & Sites: voici le correctif 1

Qu’est-ce que jQuery Migrate et pourquoi WordPress l’a-t-il supprimé?

Pas de jQuery Migrate dans WordPress 5.5

jQuery Migrate est une bibliothèque javascript. Cela a aidé les plugins et les thèmes obsolètes à fonctionner correctement sur la nouvelle version de jQuery. Avec l’aide de jQuery migrate, les plugins qui étaient compatibles avec l’ancienne version de jQuery et non mis à jour selon la nouvelle version de jQuery ont pu s’exécuter. Cependant, comme WordPress se met à jour vers la dernière version prise en charge de jQuery, l’ancienne version des plugins devait être mise à jour avec elle.

WordPress l’a annoncé avant la sortie de WordPress 5.5 que la suppression de la migration jQuery est nécessaire pour que cette transition se déroule sans heurts.

Comment résoudre les problèmes de WordPress 5.5 avec jQuery Migrate Helper?

Bien que WordPress ait supprimé l’outil jQuery Migrate, vous pouvez contourner le problème pour le moment. Pour ce faire, vous devez installer un plugin développé par l’équipe officielle de WordPress, le Aide à la migration jQuery.

WordPress 5.5 Breaks Plugins & Sites: voici le correctif 2

Ce plugin vous aide à réactiver l’outil jQuery Migrate, afin que vos plugins obsolètes puissent toujours fonctionner. Cependant, WordPress l’a développé uniquement comme une solution temporaire, pas permanente.

Pendant ce temps, tous les plugins et thèmes doivent être mis à jour et doivent être compatibles avec la nouvelle version de jQuery afin de fonctionner correctement à l’avenir.

WordPress 5.5 Breaks Plugins & Sites: voici le correctif 3

Que faire si vous êtes un développeur

Si vous êtes développeur, il est temps de mettre à jour votre plugin ou votre thème afin de fournir au client une expérience fluide. WordPress a publié un plugin appelé Tester les mises à jour jQuery, afin de vous aider à vérifier votre plugin par rapport à la nouvelle version de jQuery avant de les mettre à jour sur le référentiel WordPress.

Méfiez-vous du fait que lors de l’activation de ce plugin ne remplacera pas le jQuery actuel mais il désactivera jQuery Migrate.

Mettez à jour vos plugins et vos thèmes

En tant que propriétaire de site, chaque fois que le développeur de votre plugin supprime une nouvelle mise à jour, essayez de la mettre à jour dès que possible. Les nouvelles mises à jour minimisent un grand nombre de mises à jour de sécurité et de problèmes de compatibilité. Avec le nouveau « Plugin de mise à jour automatique»De WordPress, il est désormais encore plus facile de maintenir votre site Web à jour et en toute sécurité.

Newsletter

Entrez votre adresse mail ci-dessous pour vous abonner à notre lettre d'information

Laissez une réponse

DECOUVEREZ COMMENT OBTENIR DU TRAFIC GRATUIT ET ILLIMITE VERS VOTRE SITE OU BLOG WORDPRESS

Apprenez Pas à Pas à Générer Du Trafic Et Passer de 0 à 500 Visiteurs Quotidiens